蓝桥杯 - 负载均衡

输入样例:

2 6
5 5
1 1 5 3
2 2 2 6
3 1 2 3
4 1 6 1
5 1 3 3
6 1 3 4

输出样例:

2
-1
-1
1
-1
0

解析: 

        优先队列,排序规则为任务结束的时间,在新任务的时候,弹出已经结束的任务,并且恢复算力,然后进行判断即可。

#include<bits/stdc++.h>
using namespace std;
const int N=2e5+5;
int n,m,arr[N];
struct node{
	int start,id,time,num;
	bool operator<(const node& a)const{
		return start+time>a.start+a.time;
	}
};
priority_queue<node>q;
int main(){
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++) scanf("%d",&arr[i]);
	for(int i=1;i<=m;i++){
		int a,b,c,d;
		scanf("%d%d%d%d",&a,&b,&c,&d);
		while(!q.empty()&&q.top().start+q.top().time<=a){
			arr[q.top().id]+=q.top().num;
			q.pop();
		}
		if(arr[b]<d){
			printf("-1\n");
			continue;
		}
		else{
			arr[b]-=d;
			q.push({a,b,c,d});
			printf("%d\n",arr[b]);
		}
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值