P7001 [NEERC2013] Fraud Busters(模拟)

[NEERC2013] Fraud Busters

题面翻译

给定一个含未知字符的长度为9字符串,未知字符用’*'表示(不含引号)。下面给出n个长度为9字符串,如果下面输入的字符串与一开始输入的字符串除未知部分的其他部分完全相同,则该字符串符合要求。输出符合要求的字符串的数量和每个符合要求的字符串。

举例:假设一开始输入的字符串为A58**52*1,则字符串A58ZS52T1符合要求,而字符串A589992G1不符合要求

题目描述

The number of cars in Default City that travel to the city center daily vastly exceeds the number of available parking spots. The City Council had decided to introduce parking fees to combat the problem of overspill parking on the city streets. Parking fees are enforced using an automated vehicle registration plate scanners that take a picture of the vehicle registration plate, recognize the sequence of digits and letters in the code on the plate, and check the code against a vehicle registration database to ensure that parking fees are dutifully paid or to automatically issue a fine to the vehicle owner otherwise.

As soon as parking fees were introduced, a parking fee fraud had appeared. Some vehicle owners had started to close one or several digits or letters on their vehicle registration plate with pieces of paper while they park, thus making it impossible for the current version of the automated scanner to recognize their vehicle’s registration code and to issue them a fine.

The Default City Council had instituted the Fraud Busters Initiative (FBI) to design a solution to prevent this kind of fraud. The overall approach that FBI had selected is to expand the number of vehicle features that scanners recognize (including features like vehicle type and color), as well as excluding from the list any vehicles that are detected to be elsewhere at this time. This information should help to identify the correct vehicle by narrowing down the search in the vehicle registration database.

You are working for FBI. Your colleagues had already written all the complex pieces of the recognition software that analyses various vehicle features and provides you with a list of registration codes that might potentially belong to a scanned car. Your task it to take this list and a recognized code from the license plate (which may be partially unrecognized) and find all the registration codes that match.

输入格式

The first line of the input file contains 9 9 9 characters of the code as recognized by the scanner. Code that was recognized by the the scanner is represented as a sequence of 9 9 9 digits, uppercase English letters, and characters ‘ × ‘ ( s t a r ) . ` \times ` (star). ×(star). Star represents a digit or a letter that scanner could not recognize.

The second line of the input file contains a single integer number n ( 1 ≤ n ≤ 1000 ) n (1 \le n \le 1000) n(1n1000) – the number of vehicle registration codes from the vehicle registration database.

The following n n n lines contain the corresponding registration codes, one code per line. Vehicle registration codes are represented as a sequence of 9 9 9 digits and uppercase English letters. All codes on these n n n lines of the input file are different.

输出格式

On the first line of the output file write a single integer k ( 0 ≤ k ≤ n ) k (0 \le k \le n) k(0kn) – the number of codes from the input file that match the code that was recognized by the scanner. The code from the scanner matches the code from the database if the characters on all the corresponding positions in the codes are equal or the character from the scanner code is ‘ × ‘ . ` \times `. ב.

On the following k k k lines write the matching codes, one code per line, in the same order as they are given in the input file.

样例 #1

样例输入 #1

A**1MP19*
4
A001MP199
E885EE098
A111MP199
KT7351TTB

样例输出 #1

2
A001MP199
A111MP199

提示

Time limit: 1 s, Memory limit: 128 MB.

#include<bits/stdc++.h>
using namespace std;
//#define int long long
const int N=1e6+5;
void solve(){
	string s;
	int n;
	cin>>s>>n;
	vector<string>res;
	for(int i=1;i<=n;i++){
		string p;
		cin>>p;
		int f=1;
		for(int j=0;j<9;j++){
			if(s[j]!='*'&&s[j]!=p[j]){
				f=0;
				break;
			}
		}
		if(f) res.push_back(p);
	}
	cout<<res.size()<<endl;
	for(int i=0;i<res.size();i++) cout<<res[i]<<endl;
}
signed main(){
	int t=1;
//	scanf("%lld",&t);
	while(t--) solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值