hdu 4027 线段树

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 6849    Accepted Submission(s): 1566


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6
 

Source
 

Recommend
lcy
 
最多开7次方~~~设标记,如果子树都是一,则直接返回不更新。。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
const int MAXN=100005;
struct node
{
    int l,r;
    long long sum;
    int lazy;
    int mid()
    {
        return (l+r)>>1;
    }
};
node tree[MAXN*4];
inline void pushup(int pos)
{
    tree[pos].sum=tree[pos<<1].sum+tree[pos<<1|1].sum;
    if(tree[pos<<1].lazy==1&&tree[pos<<1|1].lazy==1)
        tree[pos].lazy=1;
    else
        tree[pos].lazy=0;
}
void build(int l,int r,int pos)
{
    tree[pos].l=l;
    tree[pos].r=r;
    if(l==r)
    {
        scanf("%I64d",&tree[pos].sum);
        if(tree[pos].sum==1)
            tree[pos].lazy=1;
        else
            tree[pos].lazy=0;
        return ;
    }
    int mid=tree[pos].mid();
    build(l,mid,pos<<1);
    build(mid+1,r,pos<<1|1);
    pushup(pos);
}
void update(int l,int r,int pos)
{
    if(tree[pos].lazy)
        return ;
    if(tree[pos].l==tree[pos].r)
    {
        tree[pos].sum=(long long)sqrt((double)tree[pos].sum);
        if(tree[pos].sum==1)
            tree[pos].lazy=1;
        return ;
    }
    int mid=tree[pos].mid();
    if(r<=mid)
        update(l,r,pos<<1);
    else if(l>mid)
        update(l,r,pos<<1|1);
    else
    {
        update(l,mid,pos<<1);
        update(mid+1,r,pos<<1|1);
    }
    pushup(pos);
}
long long query(int l,int r,int pos)
{
    if(l==tree[pos].l&&r==tree[pos].r)
        return tree[pos].sum;
    int mid=tree[pos].mid();
    if(r<=mid)
        return query(l,r,pos<<1);
    else if(l>mid)
        return query(l,r,pos<<1|1);
    else
        return query(l,mid,pos<<1)+query(mid+1,r,pos<<1|1);
}
int main()
{
    int n;
    int cas=0;
    while(scanf("%d",&n)!=EOF)
    {
        build(1,n,1);
        int q;
        cas++;
        scanf("%d",&q);
        printf("Case #%d:\n",cas);
        while(q--)
        {
            int t,x,y;
            scanf("%d%d%d",&t,&x,&y);
            if(x>y)
            {
                int temp=x;
                x=y;
                y=temp;
            }
            if(t==0)
                update(x,y,1);
            else
            {
                long long a=query(x,y,1);
                printf("%I64d\n",a);
            }
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值