A Math Problem

//这儿直接用pow函数会出错WA,不明白
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
typedef long long LL;


int main()
{
    long long n;
    while(scanf("%lld", &n) != EOF)
    {
       long long i, k;
       for(i=15; i>=1; i--)
       {
           if(pow(i, i) <= n)
           {
               k = i;
               break;
           }
       }
       printf("%lld\n", k);
    }
    return 0;
}

You are given a positive integer n, please count how many positive integers k satisfy  kknkk≤n
InputThere are no more than 50 test cases. 

Each case only contains a positivse integer n in a line. 

1n10181≤n≤1018 
OutputFor each test case, output an integer indicates the number of positive integers k satisfy  kknkk≤n in a line.Sample Input
1
4
Sample Output
1
2
#include<iostream>
#include<stdio.h>
#include<math.h>
typedef long long LL;

/*LL pow(LL a, int b)
{
    LL ans=1, base=a;
    while (b > 0)
    {
        if (b & 1)
            ans *= base;
        base = base*base;
        b >>= 1;
    }
    return ans;
}
*/
LL a[17] = {0, 1, 4, 27, 256, 3125, 46656, 823543, 16777216, 387420489, 10000000000, 285311670611, 8916100448256, 302875106592253, 11112006825558016, 437893890380859375};
int main()
{
    long long n;

/*    for(int i=1; i<=15; i++)

        printf("%lld\n", (long long)pow(i, i));//这儿必须强制类型转换,目前还不明白
*/

   while(scanf("%lld", &n) != EOF)
    {

       int i, k;

       for(i=15; i>=1; i--)
            {
             if(a[i] <= n)
                {
                    k = i;
                    break;
                }
           }
            printf("%d\n", k);


/*       for(i=15; i>=1; i--)
       {
          if(pow(i, i) <= n)
           {
               k = i;
               break;
           }
      }
       printf("%lld\n", k);
*/    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值