A - A Math Problem

You are given a positive integer n, please count how many positive integers k satisfy kknkk≤n
InputThere are no more than 50 test cases.  Each case only contains a positivse integer n in a line.  1n10181≤n≤1018  OutputFor each test case, output an integer indicates the number of positive integers k satisfy kknkk≤n in a line.Sample Input
1
4
Sample Output
1
2

解题思路:对于这个题,一点是数据很大,所以记得开long long,我第一次忘记开了,WA了一发,然后就是计算一下10的18次方附近的数值,会发现是15 的 15 和16的 16 之间所以打个一小小的表就可以了
#include<stdio.h>
#include<string.h>
int main()
{
	long long int a[51];
	for(long long int i = 1; i < 16;i++)
	{
		a[i] = 1;
		for(long long int j = 1; j <= i;j++)
		{
			a[i] = a[i]*i;
		}
	}
	
	
	long long int n;
	while(~scanf("%lld",&n))
	{
		int ans = 0;
		for(int i = 1; i < 16;i++)
		{
			if(n >= a[i])
			ans++;
			if(n < a[i])
			break;
		}
		printf("%d\n",ans);
		
	}
	return 0;
}

The 0-1 Knapsack Problem is a classic optimization problem in computer science and mathematics. The problem is as follows: Given a set of items, each with a weight and a value, determine the items to include in a collection so that the total weight is less than or equal to a given limit and the total value is as large as possible. The 0-1 indicates that each item can only be included once or not at all. This problem can be solved using dynamic programming. We can create a two-dimensional array where the rows represent the items and the columns represent the weight limit. For each item and weight limit, we can calculate the maximum value that can be obtained by either including the item or excluding it. We can then fill in the array row by row until we reach the final row, which represents the optimal solution. Here is an example implementation of the 0-1 Knapsack Problem in Java: ``` public class Knapsack { public static int knapsack(int[] values, int[] weights, int limit) { int[][] dp = new int[values.length + 1][limit + 1]; for (int i = 1; i <= values.length; i++) { for (int j = 1; j <= limit; j++) { if (weights[i-1] > j) { dp[i][j] = dp[i-1][j]; } else { dp[i][j] = Math.max(dp[i-1][j], dp[i-1][j-weights[i-1]] + values[i-1]); } } } return dp[values.length][limit]; } public static void main(String[] args) { int[] values = {60, 100, 120}; int[] weights = {10, 20, 30}; int limit = 50; int result = knapsack(values, weights, limit); System.out.println("Maximum value: " + result); } } ``` In this example, we have three items with values of 60, 100, and 120 and weights of 10, 20, and 30, respectively. We want to find the maximum value we can obtain with a weight limit of 50. The result is 220, which indicates that we should select items 2 and 3 to maximize the value while staying under the weight limit.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值