C++ STL(Standard Template Library)标准库一一集合 set

集合 set

  set就是集合,每个元素最多只出现一次,和sort一样,自定义类型也可以构造set,但同样必须定义“小于”运算符。

例:安迪的第一个字典

  一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出。单词不区分大小写

样例输入:

  Adventures in Disneyland
  Two blondes were going to Disneyland when they came to a fork in the road. The sign read: “Disneyland Left.”
  So they went home.

样例输出:

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;

set <string> dict; //string 集合
int main()
{
    string s,buf;
    while (cin>>s)
    {
        for(int i=0;i<s.length();i++)
            if(isalpha(s[i])) s[i]=tolower(s[i]);else s[i]=' ';
        stringstream ss(s);
        while(ss>>buf) dict.insert(buf);
    }
    for(set<string>::iterator it =dict.begin();it!=dict.end();++it)
        cout<<*it<<endl;
    return 0;
}

stringstream 类:

字符串流,用于数据类型转换

int main()
{
    string s="1237218738";
    stringstream ss(s);//将s复制到ss中
    int n=0;
    ss<<s; 
    ss>>n;//转换为int类型将ss的值赋值给n
    cout<<n+1; //为1237218739
}

isalpha:

判断字符是否为英文字母,若为英文字母,返回非0(小写字母为2,大写字母为1 )若不是字母,返回0

tolower:

tolower是一种函数,功能是把字母字符转换成小写,非字母字符不做出处理。

iterator:

迭代器,遍历容器的所有元素

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值