CourseGrading 题目解析

【问题描述】若某元素在一组数中比它大元素越多,则说明这个数在这组数的值就越小。现请你统计出数组中的每个元素,数一数该数组有多少个元素比它大。

【输入形式】第一行:N 第二行:N个整数

【输出形式】N个整数,各数这之间有1个空格

【样例输入】

5 
4 6 12 16 8

【样例输出】

4 3 1 0 2

个人答案

#include<iostream>
using namespace std;
int main()
{
	int temp[100];
	int N, count = 0;
	cin >> N;

	while (count < N)
	{
		cin >> temp[count];
		count++;
	}
	count = 0;
	int judged = 0;
	int out = 0;
	mark:while (count < N)
	{

		if(temp[judged]<temp[count]) //循环遍历判断
		{
			out++;
			count++;
			continue;  //continue语句避免后续无效判断
		}
		if (temp[judged] >temp[count])
		{
			count++;
			continue;
		}
		if (temp[judged] == temp[count])
		{
			count++;
			continue;
		}
		
	}
	cout << out << " ";
	out = 0;
	count = 0;  //清零计数器
	
	if(judged<N-1)
	{
		judged++;
		goto  mark;//不推荐使用goto语句
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值