统计比指定元素大的个数(c语言)
统计比指定元素大的个数-hebust
统计比指定元素大的个数
输入格式:
输入为2行,第一行为参照的整数元素,第二行为参与统计的整数元素,之间使用空格分割。
输出格式:
输出为比指定的参照元素大的元素个数。
输入样例:
在这里给出一组输入。例如:
5
2 3 6 7 3 4 9 8
输出样例:
在这里给出相应的输出。例如:
4
#include <stdio.h>
#include <stdlib.h>
#include<ctype.h>
int main()
{
int a,b[1000],i=0,j=0;
char c;
scanf("%d",&a);
for(j=0;j<1000;j++)b[j]=9999;
j=0;
getchar();
while((c=getchar())!='\n')
{
if(isdigit(c))
{
ungetc(c,stdin);
scanf("%d",&b[j++]);
}
}
for(j=0;b[j]!=9999;j++){
if(b[j]>a){
i++;
}
}
printf("%d",i);
return 0;
}