hdu2844_多重背包

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
  
  
8 4
很明显的多重背包的题目,很适合练手。我们只需要注意当物品的weight>背包的Volume的时候这个就变成了完全背包,如果小于的时候就把多重背包转变成二进制的01背包,如15 可以用2 4 8 1进行表示 加快效率
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include<cmath>
using namespace std;
long long dp[100005];
int n,m;
#define INF -1234567890
void onezeropack(int val,int w){
	for(int i=m;i>=w;i--){
		dp[i]=max(dp[i],dp[i-w]+val);
	}
}
void completepack(int val,int w){
	for(int i=val;i<=m;i++){
		dp[i]=max(dp[i],dp[i-w]+val);
	}
}
void multipack (int val,int w,int c){
	if(c*val>m){
		completepack(val,w);//价值与数目的总和大于了给出的限制 所以这一个循环把多重背包看作完全背包 
		return ;
	}
	else {
		int k=1;
		while(k<=c){
			onezeropack(val*k,w*k);//如果小于 则看作一个01背包 进行二进制优化 把一个数拆分成多个数的累积 
			c-=k;
			k*=2;
		}//二进制优化处理
		onezeropack(c*val,c*w); 
	}
	return ;
}
int main(){
	while(scanf("%d%d",&n,&m)==2&&(n+m!=0)){
		int weight[105],c[105];
		for(int i=1;i<=n;i++){
			scanf("%d",&weight[i]);
		}
		for(int i=1;i<=n;i++){
			scanf("%d",&c[i]);
		}
		for(int i=0;i<=m;i++)dp[i]=INF;
		dp[0]=0;
		for(int i=1;i<=n;i++){
			multipack(weight[i],weight[i],c[i]);//第一个参数是价值(这题也是weight)第二个是weight 第三个是数量 
		}
		int ans=0;
		for(int i=1;i<=m;i++){
			if(dp[i]>0)ans++;
		}
		printf("%d\n",ans);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值