女生赛HDU6024

HDU’s  n  classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these  n  classrooms.

The total cost consists of two parts. Building a candy shop at classroom  i  would have some cost  ci . For every classroom  P  without any candy shop, then the distance between  P  and the rightmost classroom with a candy shop on  P 's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
 

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer  n(1n3000) , denoting the number of the classrooms.
In the following  n  lines, each line contains two integers  xi,ci(109xi,ci109) , denoting the coordinate of the  i -th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
 

Output
For each test case, print a single line containing an integer, denoting the minimal cost.
 

Sample Input
  
  
3 1 2 2 3 3 4 4 1 7 3 1 5 10 6 1
 

Sample Output
  
  
5 11
 

Source


DP题 dp[i][j]表示的是在第个教师中建(j=1)不建(j=0)所需要的花费值 然后两个for一下即可,注意路径是一直叠加的。如果第i个不建造,第i-1 i-2 也不造,他们的花费是一直要更新的。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define ll long long
#define INF 1e10 
struct N{
	ll x,c;
	bool operator <(N& a){
		return this->x<a.x;
	}
	N():x(0),c(0){
	}
};
ll dp[3005][2];
	int main(){
	int n;
	while(cin>>n){
		N a[3005];
		for(int i=1;i<=n;i++){
			cin>>a[i].x>>a[i].c;	
		}
		sort(a+1,a+n+1);
		for(int i=0;i<=n;i++){
			dp[i][0]=INF;
			dp[i][1]=INF;
		}
		dp[0][1]=0;//dp[i][j]到第i个店位置 建不建糖果店他们的花费,1建造,0不造 
		dp[0][0]=0;
		for(int i=1;i<=n;i++){
			dp[i][1]=min(dp[i-1][1],dp[i-1][0])+a[i].c;//要建造那么花费的是钱
			ll cost=0;
			for(int j=i-1;j>=1;j--){
				cost+=(i-j)*(a[j+1].x-a[j].x);	
				dp[i][0]=min(dp[i][0],dp[j][1]+cost);
			} 
		} 
		ll ans = dp[n][1]>dp[n][0]?dp[n][0]:dp[n][1];
		cout<<ans<<endl;
	}
	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值