【PAT乙级】1044 火星数字 (20分)

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N N N < 100 <100 <100),随后 N N N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

解题思路:

答案代码:

#include<iostream>
#include<string>
using namespace std;

string units[13] = {
    "tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"
};
string tens[13] = {
    "   ", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"
};

void etom(int e) {
    if (e / 13) cout << tens[e / 13];
    if ((e / 13) && (e % 13)) cout << " ";
    if (e % 13 || e == 0) cout << units[e % 13];
}

void mtoe(string s) {
    string s1 = s.substr(0,3), s2;
    if (s.size() > 4) s2 = s.substr(4,3);

    int num1 = 0, num2 = 0;
    for (int i = 1; i <= 12; i++) {
        if (s1 == tens[i])    num1 = i;
        if (s1 == units[i] || s2 == units[i]) num2 = i;
    }
    cout << num1*13 + num2;
}

int main() {
    int n;
    cin >> n;
    getchar();
    
    string s;
    for (int i = 0; i < n; i++) {
        getline(cin, s);
        isdigit(s[0]) ? etom(stoi(s)) : mtoe(s);
        cout << endl;
    }
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值