已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

求二叉树的先序遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 

Output

 输出二叉树的先序遍历序列

Sample Input

2
dbgeafc
dgebfca
lnixu
linux

Sample Output

abdegcf
xnliu
#include <stdio.h>
#include <stdlib.h>
char s[1500];
typedef struct
{
    char data;
    struct tree *Lchild;
    struct tree *Rchild;
}tree;


struct tree * pai(char *hou, char *zhong, int len)
{
    if(len == 0)
        return NULL;
    tree *temp = (tree *)malloc(sizeof(tree));
    temp -> data = hou[len-1];//这里和先序不同,要从后面读取
    int i;
    for(i=0;i<len;i++)
    {
        if(zhong[i]==hou[len-1])
        {
            break;
        }
    }
    temp -> Lchild = pai(hou, zhong,i);
    temp -> Rchild = pai(hou+i, zhong+i+1, len-i-1);
    return temp;
};





levelshow(tree *head)
{
    tree *temp[100];
    int front=0, rear=-1;
    temp[++rear] = head;
    while(rear>=front)
    {
        if(temp[front])
        {
        printf("%c", temp[front]->data);
        temp[++rear] = temp[front]->Lchild;
        temp[++rear] = temp[front]->Rchild;
        }
        front++;
    }

}

show(tree *temp)
{
    if(temp)
    {
        printf("%c", temp->data);
        show(temp->Lchild);
        show(temp->Rchild);
    }
}

int main()
{
    char zhong[100], hou[100];
    int i, len;
    tree *head;
    int n;
    scanf("%d", &n);
    while(n--)
    {
    scanf("%s", zhong);
    scanf("%s", hou);
    len = strlen(zhong);
    head = pai(hou, zhong, len);//建树
    show(head);
    printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 14
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值