2. A+B——the first step

1000 1001

A + B Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 704421    Accepted Submission(s): 217867


Problem Description
Calculate A + B.
 

Input
Each line will contain two integers A and B. Process to end of file.
 

Output
For each case, output A + B in one line.
 

Sample Input
  
  
1 1
 

Sample Output
  
  
2
 

Author
HDOJ
#include<iostream>   
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<iomanip>
#include<cstdio>
using namespace std;
int main()
{
    /*ios::sync_with_stdio(false);
    cin.tie(0);
理论上,scanf 和 printf 要比cin 和 cout 快,但是加上这两行之后就会使
cin cout比 scanf printf 都要快。
但是用了“
    ios::sync_with_stdio(false);
    cin.tie(0);
    “
    之后,scanf 和 printf 都不能使用了,只能使用cin 和 cout。
    详见http://blog.csdn.net/jinzhilong580231/article/details/7697608
    http://www.cnblogs.com/bofengyu/p/6720041.html
    等其他相关操作*/
    int a,b,sum=0;
    while(cin>>a>>b)
    {
         sum=a+b;
        cout<<sum<<endl;
    }
 return 0;  
}

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 502828    Accepted Submission(s): 127638


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
   
   
1 100
 

Sample Output
   
   
1 5050
 

Author
DOOM III
#include <iostream>
using namespace std;

int main()
{
    long long n;
    while( cin>>n )
    {
        cout<<( n*(n+1) ) / 2<<endl<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值