POJ 2549 Sumsets hash

G - Sumsets
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.
Input
Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.
Output
For each S, a single line containing d, or a single line containing “no solution”.
Sample Input
5
2
3
5
7
12
5
2
16
64
256
1024
0
Sample Output
12
no solution


#include<iostream>
#include<cstring>
#include<algorithm>
#include<functional>
using namespace std;
const int MAX = 7357737;
const int MIN = -536870912 * 2 - 1;
struct HashNode
{
    int val, x, y, next;
};
int S[1005], N, head[MAX + 5], cnt;
HashNode F[MAX];
void InsertHash(int key, int x, int y)
{
    int pos = (key < 0 ? -key : key) % MAX;
    F[cnt].val = key, F[cnt].next = head[pos], F[cnt].x = x, F[cnt].y = y;
    head[pos] = cnt++;
}
bool SearchHash(int key, int a, int b)
{
    int pos = (key < 0 ? -key : key) % MAX;
    for (int i = head[pos]; i != -1; i = F[i].next)
        if (key == F[i].val)
        {
            if (a == F[i].x || a == F[i].y || b == F[i].x || b == F[i].y)
                continue;
            return true;
        }
    return false;
}
int main()
{
    cin.sync_with_stdio(false);
    while (cin >> N && N)
    {
        memset(head, -1, sizeof(head));
        cnt = 0;
        for (int i = 1; i <= N; i++)
            cin >> S[i];
        for (int i = 1; i <= N; i++)
            for (int j = i + 1; j <= N; j++)
            {
                int sum = S[i] + S[j];
                InsertHash(sum, i, j);
            }
        int Ans = MIN;
        for (int i = 1; i <= N; i++)
            for (int j = 1; j <= N; j++)
            {
                if (i == j) continue;
                int sum = S[i] - S[j];
                if (SearchHash(sum, i, j))
                {
                    Ans = max(S[i], Ans);
                    j = N + 1;
                }
            }
        if (Ans == MIN) cout << "no solution\n";
        else cout << Ans << '\n';
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值