【POJ 2549 Sumsets】+ 技巧枚举

Sumsets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11084 Accepted: 3032
Description

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.
Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.
Output

For each S, a single line containing d, or a single line containing “no solution”.
Sample Input

5
2
3
5
7
12
5
2
16
64
256
1024
0
Sample Output

12
no solution

把两个的和 用数组保存起来,然后 用差二分查找,有可能会有一样的~~然后这样枚举居然没超时~QAQ

AC代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int K = 1e4 + 10;
int a[K];
int main()
{
    int N;
    while(scanf("%d",&N) != EOF && N){
        for(int i = 1; i <= N; i++)
            scanf("%d",&a[i]);
        sort(a + 1, a + 1 + N);
        int ok = 1,ans = 0;
        for(int i = N; i >= 1 && ok; i--)
           for(int j = N; j >= 1 && ok; j--){
               if(i == j) continue;
                ans = a[i] - a[j];
               for(int l = 1,r = j - 1; ok && l < r;){
                    if(a[l] + a[r] == ans) ans = a[i],ok = 0;
                    else if(a[l] + a[r] > ans) r--;
                    else l++;
               }
        }
        if(ok) printf("no solution\n");
        else printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值