hdu - 1506 dp ,找最左最右边界

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000


题意:

找一个最大矩形;

思路:

一般思想是从a[i] 往左找比a[i]大的连续的最左边界, 往右找比a[i]大的连续的最右边界 
 若用一般的方法,一定会超时,在这里就要用到dp的思想,

首先 开 三个数组:

// a[i] 存第i个的高度
// l[i]  当高度为a[i] 时,矩形的最左边界; 
// r[i] 当高度为a[i] 时,矩形的最右边界;

看代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

__int64 a[100005],l[100005],r[100005];
// a[i] 存第i个的高度
// l[i]  当高度为a[i] 时,矩形的最左边界; 
// r[i] 当高度为a[i] 时,矩形的最右边界;
 
int main()
{
	int i,j,k,t,n;
	while(~scanf("%d",&n))
	{
		if(n==0)
			break;
		for(i=1;i<=n;i++)
			scanf("%I64d",&a[i]);
		l[1]=1;   // 第一个最左边界一定是1; 
		r[n]=n;		// 最后一个大最右边界 一定是n; 
		
		for(i=2;i<=n;i++)   	//找左边界时要从左往右找, 
		{						// 为什么?这里有dp的思想,dp 就是一步步递推的,自己要想通; 
			int tt=i;
			while(tt>1&&a[i]<=a[tt-1])  //  找左边界时,先与自己左边第一个比较,若大于自己,再找左边第一个的左边界,例如是tt;
				tt=l[tt-1];	// 再让tt左边第一个的高度与自己比较,依次类推;
			l[i]=tt;
		}
		
		for(i=n-1;i>=1;i--)   	//找右边界时要从右往左找 
		{
			int tt=i;
			while(tt<n&&a[i]<=a[tt+1]) // 找右边界时,和找左边界思想一样; 
				tt=r[tt+1];
			r[i]=tt;
		}
		
		__int64 ans=0;
		
		for(i=1;i<=n;i++)
			ans=max(ans,a[i]*(r[i]-l[i]+1));
		printf("%I64d\n",ans);
	}
	return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值