HDU-1505 最大矩形问题(二)

这是这一系列的第二题,其实讲白了还是用第一题的方法解:
就是刚开始把问题想复杂了,我发现大部分ACM题目都不能太复杂的去想,思路要简单清晰的好:
HDU-1505:
F - City Game
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.  

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.  

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.  

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:  

R – reserved unit  

F – free unit  

In the end of each area description there is a separating line.  

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0

思路:
在第一题的基础上多加一个而为数组dp[m][n],对于每一个点dp[i][j]表示在第j列,到第i行为止,连续的F的个数,如果上一行为dp[i-1][j]为3,如果地图里面map[i][j]为F的话,dp[I][j]=dp[I-1][j]+1=4,但如果map[I][j]=R,则计数清零dp[I][j]=0;下一行从1开始计数,这样每一行dp都可以看成是第一题里面的高了,对于每一行用第一题求最大矩形的方法解,然后遍历每一行,找到最大的S就行了;

下面上代码:
//Li Wenjun
//emai:1542113545@qq.com
/*
「“04.24,サクラと东京スカイツリーに行った。そこは世界で一番暖かいところだ。”
“04.26,サクラと明治神宫に行った。そこで结婚式お挙げる人がいた。”
“04.25,サクラとデイズニーに行った。お化け屋敷が怖かったけど、サクラがいたから、全然怖くわなかった。”
“サクラのことが大好き。”」
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include <iostream>
#include <algorithm>
using namespace std;
int dp[1005][1005],r[1005],l[1005];
int n,m,maxs;
int FindMax(int H)
{
    int temp,i,j;
    for(i=1;i<=m;i++)
    {
        r[i]=l[i]=i;
        while(dp[H][l[i]-1]>=dp[H][i])
            l[i]=l[l[i]-1];
    }
    for(j=m;j>=1;j--)
    {
        while(dp[H][r[j]+1]>=dp[H][j])
            r[j]=r[r[j]+1];
          temp=dp[H][j]*(r[j]-l[j]+1);
        if(maxs<temp)
            maxs=temp;
    }
    return 0;
}
int main()
{
   // freopen("in.txt","r",stdin);
    int cases;
    char a;
    cin>>cases;
    while(cases--)
    {
        cin>>n>>m;
        memset(dp,0,sizeof(dp));
        dp[n+1][0]=-2;
        for(int i=1;i<=n;i++)
        {
            dp[i][0]=-1;
            for(int j=1;j<=m;j++)
            {
                cin>>a;
                if(a=='R')
                {
                    dp[i][0]=-2;
                    dp[i][j]=0;
                }
                else
                {
                    dp[i][j]=dp[i-1][j]+1;
                }
            }
            dp[i][m+1]=-1;
        }
        maxs=0;
        for(int i=1;i<=n;i++)
        {
            if(dp[i+1][0]==-2)
             FindMax(i);
        }
        cout<<maxs*3<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值