HDU1429 胜利大逃亡(续)(bfs+状态压缩)

5 篇文章 0 订阅
5 篇文章 0 订阅

胜利大逃亡(续)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7267    Accepted Submission(s): 2516


Problem Description
Ignatius再次被魔王抓走了(搞不懂他咋这么讨魔王喜欢)……

这次魔王汲取了上次的教训,把Ignatius关在一个n*m的地牢里,并在地牢的某些地方安装了带锁的门,钥匙藏在地牢另外的某些地方。刚开始Ignatius被关在(sx,sy)的位置,离开地牢的门在(ex,ey)的位置。Ignatius每分钟只能从一个坐标走到相邻四个坐标中的其中一个。魔王每t分钟回地牢视察一次,若发现Ignatius不在原位置便把他拎回去。经过若干次的尝试,Ignatius已画出整个地牢的地图。现在请你帮他计算能否再次成功逃亡。只要在魔王下次视察之前走到出口就算离开地牢,如果魔王回来的时候刚好走到出口或还未到出口都算逃亡失败。
 

Input
每组测试数据的第一行有三个整数n,m,t(2<=n,m<=20,t>0)。接下来的n行m列为地牢的地图,其中包括:

. 代表路
* 代表墙
@ 代表Ignatius的起始位置
^ 代表地牢的出口
A-J 代表带锁的门,对应的钥匙分别为a-j
a-j 代表钥匙,对应的门分别为A-J

每组测试数据之间有一个空行。
 

Output
针对每组测试数据,如果可以成功逃亡,请输出需要多少分钟才能离开,如果不能则输出-1。
 

Sample Input
  
  
4 5 17 @A.B. a*.*. *..*^ c..b* 4 5 16 @A.B. a*.*. *..*^ c..b*
 

Sample Output
  
  
16 -1
 

Author
LL
 

Source
 
思路:用状态压缩表示当前拥有的钥匙状态,简单的bfs。
#include <stdio.h>
#include <string.h>
#include <queue>
#define ll long long int
using namespace std;
char Map[25][25];
int vis[25][25][(1<<10)+10];
int limt, n, m;
int dx[] = {1, -1, 0, 0}, dy[] = {0, 0, 1, -1};
struct Node{
    int x, y, t;
    ll key;
    Node(){}
    Node(int x1, int y1, int t1, ll key1){
        x = x1, y = y1, t = t1, key = key1;
    }
    bool operator < (const Node& b)const{return t>b.t;}
};
bool judge(int x, int y){
    if(x>=0&&x<n&&y>=0&&y<m&&Map[x][y] != '*') return 1;
    return 0;
}
int bfs(int sx, int sy){
    Node now = Node(sx, sy, 0, 0);
    Node nxt;
    priority_queue<Node> q;
    q.push(now);

    while(!q.empty()){
        now = q.top();
        q.pop();
        if(Map[now.x][now.y] == '^'&&now.t < limt) return now.t;
        if(now.t >= limt) continue;
        for(int i = 0;i < 4;i++){
            int x = now.x + dx[i];
            int y = now.y + dy[i];
            int t = now.t + 1;
            ll key = now.key;
            if(!judge(x, y)) continue;

            if(Map[x][y] >= 'A'&&Map[x][y] <= 'J'){
                ll tmp = 1<<(Map[x][y] - 'A');
                if(key&tmp);
                else continue;
            }else if(Map[x][y] >= 'a'&&Map[x][y] <= 'j'){
                ll tmp = 1<<(Map[x][y] - 'a');
                key |= tmp;
            }
            if(t < vis[x][y][key]){
//printf("%d %d\n", x, y);
                vis[x][y][key] = t;
                q.push(Node(x, y, t, key));
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d %d %d", &n, &m, &limt) != EOF){
        for(int i = 0;i < n;i++) scanf("%s", Map[i]);
        int sx, sy;
        for(int i = 0;i < n;i++){
            for(int j = 0;j < m;j++){
                if(Map[i][j] == '@'){
                    sx = i, sy = j;
                    break;
                }
            }
        }
        memset(vis, 127, sizeof vis);
        printf("%d\n", bfs(sx, sy));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值