UVA-10474 Where is the Marble

题目描述

给一堆石头排序,找到问题所问的数字,若存在则输出第几块石头(从1开始),若不存在则说not found。

Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

//
// Created by yoyoOvQ on 2021/2/3.
//

#include <iostream>
#include <fstream>
#include <algorithm>
const int maxn = 10005;
using namespace std;
int main(){
#ifndef ONLINE_JUDGE
    ifstream cin("UVa/in/in-10474.txt");
    ofstream cout("UVa/out/out-10474.txt");
#endif
    int N,Q,count = 0;
    while (cin >> N >> Q && N && Q){
        cout << "CASE# " << ++count << ":" << endl;
        int a[maxn];
        for (int i = 0; i < N; ++i) {
            cin >> a[i];
        }

        sort(a,a+N);
        int ans;
        int q;
        for (int i = 0; i < Q; ++i) {
            cin >> q;
            ans = lower_bound(a,a+N,q) - a;
            if (a[ans] == q)
                cout << q << " found at " << ans + 1 << endl;
            else
                cout << q << " not found" << endl;
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值