2013(跟2014一样的)

1014

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 &lt;= Ki &lt;= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button &quot;UP&quot; , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button &quot;DOWN&quot; , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button &quot;UP&quot;, and you'll go up to the 4 th floor,and if you press the button &quot;DOWN&quot;, the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button &quot;UP&quot; or &quot;DOWN&quot;?<br>
 

Input
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5<br>3 3 1 2 5<br>0
 

Sample Output
  
  
3
 

题意:在一个N层高的楼上有一个电梯,在每一层只能上升或下降一个特定的层数,中间不会停止,在给定的条件下,问能不能到达指定楼层。可以返回操作次数,不可以的话,返回-1;


思路:之前遇到的题目,不是地图就是矩阵,这题有点不一样。我没做出来,去查了一下,发现其实思想还是那个样子。深搜就可以解决,使用队列就可以了。


AC代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <queue>
#include <climits>


using namespace std;


const int MAX = 202;
int flr[MAX],ans;
int dist[MAX];
int n,b;


void dfs(int s,int cnt){
if(s>n || s<1)return;
if(s==b){
if(cnt<ans){
ans = cnt;
return;
}
}
if(cnt>=dist[s])return;
dist[s] = cnt;
dfs(s+flr[s],cnt+1);
dfs(s-flr[s],cnt+1);
}


int main(){
//freopen("in.txt","r",stdin);


int a,i,cnt;
while(scanf("%d",&n)!=EOF && n){
scanf("%d %d",&a,&b);
for(i=1;i<=n;++i){
scanf("%d",&flr[i]);
dist[i] = INT_MAX - 10;
}
cnt = 0;
ans = INT_MAX;
dfs(a,cnt);
if(ans==INT_MAX){
printf("-1\n");
}else{
printf("%d\n",ans);
}
}


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值