A strange lift---奇怪的电梯

http://acm.hdu.edu.cn/showproblem.php?pid=1548

 

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist. 
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"? 

Input

The input consists of several test cases.,Each test case contains two lines. 
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn. 
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

 题意:在一个N层高的楼上有一个电梯,在每一层只能上升或下降一个特定的层数,中间不会停止,在给定的条件下,问能不能到达指定楼层。可以的话,返回操作次数,不可以的话,返回-1;

一开始题意都读不懂的我,根本不知道题让干啥的......失败啊~最近刚理解搜索类的题,我就趁热打铁,把以前的题都翻出来看看.....果然,现在看起来都很顺利!

啦啦啦~\(≧▽≦)/~啦啦啦~

bfs,dfs都可以~

我的ac代码~bfs+队列.....

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>                       ///声明队列
using namespace std;
int a[210],n,flag[210];
void BFS(int s,int t)
{
	int v;
	queue<int> q;
	q.push(s);
	flag[s]=1;           ///标记此时为1
	while(!q.empty())
		{
			v=q.front();
			q.pop();
			if(v==t)
				break;
			if(v+a[v]<=n&&flag[v+a[v]]==0)//向上
				{
					q.push(v+a[v]);
					flag[v+a[v]]=flag[v]+1;
				}

			if(v-a[v]>=1&&flag[v-a[v]]==0)//向下
				{
					q.push(v-a[v]);
					flag[v-a[v]]=flag[v]+1;
				}
		}
	if(v!=t)
		flag[t]=0;             ///

}
int main()
{
	int i,j,s,t;
	while(scanf("%d %d %d",&n,&s,&t),n!=0)
		{
			for(i=1; i<=n; i++)
				{
					scanf("%d",&a[i]);
				}
			memset(flag,0,sizeof(flag));
			BFS(s,t);
			printf("%d\n",flag[t]-1);            ///-1
		}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值