UVa 11475-Extend to Palindrome JAVA



Your task is, given an integer N, to make a palidrome (word that reads the same when you reverse it) of length at least N. Any palindrome will do. Easy, isn't it? That's what you thought before you passed it on to your inexperienced team-mate. When the contest is almost over, you find out that that problem still isn't solved. The problem with the code is that the strings generated are often not palindromic. There's not enough time to start again from scratch or to debug his messy code. Seeing that the situation is desperate, you decide to simply write some additional code that takes the output and adds just enough extra characters to it to make it a palindrome and hope for the best. Your solution should take as its input a string and produce the smallest palindrome that can be formed by adding zero or more characters at its end.

 

 

 

Input

 

 

 

 

Input will consist of several lines ending in EOF. Each line will contain a non-empty string made up of upper case and lower case English letters ('A'-'Z' and 'a'-'z'). The length of the string will be less than or equal to 100,000.

 

 

 

 

 

 

 

Output

 

 

 

For each line of input, output will consist of exactly one line. It should contain the palindrome formed by adding the fewest number of extra letters to the end of the corresponding input string.

 

 

 

 

 

 

 

Sample Input

Sample Output

 

 

 

 

 

aaaa
abba
amanaplanacanal
xyz

aaaa
abba
amanaplanacanalpanama
xyzyx

 

 

 

 

 


Problem Setter: Muntasir Azam Khan
Special Thanks: Rakibul Hossain
Next Generation Contest 5

题意:加最小的字符串使之成为回文

思路:KMP,训练指南上的算法拿来用了,正反比较找出重合的那一段的长度,就可以啦。

代码:

import java.util.*;
class Main{
 static int f[]=new int[100005];
 static void kmp_init(String p){
  int i,j;
  f[0]=f[1]=0;
  i=1;j=0;
  while(i<p.length()){
   if(p.charAt(i)==p.charAt(j)){
    f[++i]=++j;
   }
   else if(j==0){
    f[++i]=0;
   }
   else{
    j=f[j];
   }
  }
 }
 static int kmp(String p,String t){
  kmp_init(p);
  int i=0,j=0;
  int n=t.length(),m=p.length();
  while(i<n){
   while(j<m){
    if((i<n&&j<m&&t.charAt(i)==p.charAt(j))||(i<n&&j>=m&&t.charAt(i)==0)||(j<m&&i>=n&&p.charAt(j)==0)||(j>=m&&i>=n)){
     i++;j++;
    }
    else break;
   }
   if(j==0) i++;
   if(i==n) return j;
   j=f[j];
  }
  return 0;
 }
 public static void main(String[] args){
  Scanner scan=new Scanner(System.in);
  while(scan.hasNext()){
   String a=scan.next();
   String b=new StringBuffer(a).reverse().toString();
   String c=a.substring(0, a.length()-kmp(b,a));
   String d=new StringBuffer(c).reverse().toString();
   String ans=a+d;
   System.out.println(ans);
  }
 }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值