POJ 2782 Bin Packing


Bin Packing
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5416 Accepted: 2452

Description

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that
  • each bin contains at most 2 items,
  • each item is packed in one of the q bins,
  • the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q .

Input

The first line of the input contains the number of items n (1<=n<=10 5) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.

Output

Your program has to write the minimal number of bins required to pack all items.

Sample Input

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output

6

Hint

The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.

Source


题意:给最大长度,最多放两个,使给出的长度组合成不大于最大长度的最小组合数。

思路:贪心。最长的和最短的组合如果小于最大长度的话。

AC代码:(代码里有多组数据,懒得改吐舌头
 java.io.*;
import java.util.*;
public class Main {

	public static void main(String[] args) throws IOException {
		//Scanner scan=new Scanner (System.in);
		StreamTokenizer st = new StreamTokenizer(new BufferedReader(
				new InputStreamReader(System.in)));
		st.nextToken();
		int t=(int)st.nval;
		for(int i=0;i<t;i++){
			st.nextToken();
			int n=(int)st.nval;
			st.nextToken();
			int l=(int)st.nval;
			int count=0;
			int a[]=new int[n];
			for(int j=0;j<n;j++){
				st.nextToken();
				a[j]=(int)st.nval;
			}
			Arrays.sort(a);
			for(int j=0,k=n-1;j<=k;){
				if(a[j]+a[k]<=l){
					count++;
					j++;k--;
				}
				else{
					count++;
					k--;
				}
			}
			if(i!=0)
				System.out.println();
			System.out.println(count);
		}
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值