Expanding Rods<poj1905>

14 篇文章 0 订阅

Description

When a thin rod of length L is heated n degrees, it expands to a new length L' = (1+n*C)*L, where C is the coefficient of heat expansion.

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced. That means you have to calculate h as in the picture.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case contains three non-negative real numbers: the initial length of the rod in millimeters L, the temperature change in degrees n and the coefficient of heat expansion of the material C. Input data guarantee that no rod expands by more than one half of its original length. All the numbers will be between 0 and 1000 and there can be at most 5 digits after the decimal point.

Output

For each case, print the case number and the displacement of the center of the rod in single line. Errors less than 10-6 will be ignored.

Sample Input

3

1000 100 0.0001

150 10 0.00006

10 0 0.001

Sample Output

Case 1: 61.3289915

Case 2: 2.2502024857

Case 3: 0

给出弧长    用圆弧对应的角度二分

#include <iostream>
#include <cstdio>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <list>
#include <map>
#include <stack>
#include <vector>
#include <cmath>
#include <queue>
#define eps  1e-8
#define PI acos(-1.0)
using namespace std;
int main()
{    
      int cut=0;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		cut++;
		double L,n,c;
		scanf("%lf%lf%lf",&L,&n,&c);
		double L1=(1.0+n*c)*L;
		double l=0.0,r=PI;
		int S=100;
		double h=0;
		double R=0;
		while(S--)
	    {
	    	double mid=(l+r)/2.0;
	       R=(L/2.0)/sin(mid/2.0);
			 if(R*mid<L1)
			 {
			 	l=mid;
			 }
			 else
			 {
			 	r=mid;
			 }
		}  
             	h=R-R*cos(l/2.0);
		printf("Case %d: %.6lf\n",cut,h);
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
<?xml version="1.0" encoding="UTF-8"?> <ui version="4.0"> <widget name="__qt_fake_top_level"> <widget class="QWidget" name=""> <layout class="QVBoxLayout" name="verticalLayout"> <item> <widget class="QTextEdit" name="textEdit"> <property name="minimumSize"> <size> <width>200</width> <height>0</height> </size> </property> <property name="maximumSize"> <size> <width>200</width> <height>16777215</height> </size> </property> <property name="font"> <font> <pointsize>14</pointsize> </font> </property> </widget> </item> <item> <widget class="QTextBrowser" name="textBrowserResult"> <property name="minimumSize"> <size> <width>100</width> <height>0</height> </size> </property> <property name="maximumSize"> <size> <width>200</width> <height>16777215</height> </size> </property> <property name="font"> <font> <pointsize>28</pointsize> </font> </property> </widget> </item> <item> <widget class="QPushButton" name="pushButton_2"> <property name="text"> <string>暂停</string> </property> </widget> </item> <item> <widget class="QPushButton" name="pushButton"> <property name="text"> <string>开始</string> </property> </widget> </item> <item> <widget class="QComboBox" name="comboBox"> <property name="sizePolicy"> <sizepolicy hsizetype="Expanding" vsizetype="Maximum"> <horstretch>0</horstretch> <verstretch>0</verstretch> </sizepolicy> </property> <property name="minimumSize"> <size> <width>200</width> <height>30</height> </size> </property> <property name="maximumSize"> <size> <width>100</width> <height>30</height> </size> </property> <property name="font"> <font> <pointsize>14</pointsize> </font> </property> </widget> </item> </layout> </widget> </widget> <resources/> </ui>
最新发布
06-13
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值