LightOJ 1305Area of a Parallelogram

13 篇文章 0 订阅
10 篇文章 0 订阅

Description

A parallelogram is a quadrilateral with two pairs of parallel sides. See the picture below:

Fig: a parallelogram

Now you are given the co ordinates of A, B and C, you have to find the coordinates of D and the area of the parallelogram. The orientation ofABCD should be same as in the picture.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing six integers Ax, Ay, Bx, By, Cx, Cy where (Ax, Ay) denotes the coordinate of A(Bx, By) denotes the coordinate of B and (Cx, Cy) denotes the coordinate of C. Value of any coordinate lies in the range [-1000, 1000]. And you can assume that A, Band C will not be collinear.

Output

For each case, print the case number and three integers where the first two should be the coordinate of D and the third one should be the area of the parallelogram.

Sample Input

3

0 0 10 0 10 10

0 0 10 0 10 -20

-12 -10 21 21 1 40

Sample Output

Case 1: 0 10 100

Case 2: 0 -20 200

Case 3: -32 9 1247

 每个点的相对位置是一定的  坐标好求   对角的坐标相加是相等的
求面积 直接求三角型ABC面积*2  
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	int ans=0;
	while(t--)
    {
    	ans++;
     double x1,y1,x2,y2,x3,y3;
    	scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
       int	x4=(int)x1+x3-x2;
    	int y4=(int)y1+y3-y2;
        double c=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
        double a=sqrt((x2-x3)*(x2-x3)+(y2-y3)*(y2-y3));
        double b=sqrt((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3));
	   double s=abs(sqrt(1-(a*a+b*b-c*c)/(2*a*b)*(a*a+b*b-c*c)/(2*a*b))*a*b);
    	printf("Case %d: %d %d %.0lf\n",ans,x4,y4,s);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值