【VUE】vue引入echarts报错(echarts__WEBPACK_IMPORTED_MODULE_2__.default is undefined)

VUE 同时被 2 个专栏收录
1 篇文章 0 订阅
1 篇文章 0 订阅

一、版本问题

echarts版本在5.0以上可能会出现不支持的问题,可卸载现在版本

npm uninstall echarts

再安装4.X的版本,如:

npm install echarts@4.1.0 -save

二、引入方式

如果在引用echarts的js文件中直接导入也可能出现问题

import echarts from 'echarts'

可以把引入方式改为

import * as echarts from 'echarts'
  • 1
    点赞
  • 0
    评论
  • 1
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 游动-白 设计师:白松林 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值