poj 3159 Candies(差分约束原理 最短路)

题意:不懂差分约束的请看我转载的一篇差分约束详解http://blog.csdn.net/kirito_j/article/details/52132170

看完那个链接你们就懂了,在型如x-y<=k的题型就是以x到y的权值为k,求最短路径,但不能用vector,会超时,所以要用hash那样的构造方法来标记下标。

CandiesTime Limit:1500MS    Memory Limit:131072KB    64bit IO Format:%lld & %llu

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.
AC代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<map>
#include<set>
#define INF 999999999
#define LL long long
#define mod 1000003
#define MAX 30005
using namespace std;
int n, m;
int d[MAX];
bool done[MAX];
int head[200005];
int nextt[200005];
struct Edge
{
	int from,to, dist;
	Edge(){}
	Edge(int ffrom,int tto,int ddist):from(ffrom),to(tto),dist(ddist){}
};
Edge edges[200005];
struct HeapNode
{
	int d, u;
	HeapNode(int dd,int uu):d(dd),u(uu){}
	bool operator < (const HeapNode& rhs) const
	{
		return d > rhs.d;
	}
};
void dijiktra(int s)
{
	priority_queue<HeapNode> q;
	for (int i = 0; i <= n; i++) d[i] = INF;
	d[s] = 0;
	memset(done, 0, sizeof(done));
	q.push(HeapNode(0, s));
	while (!q.empty())
	{
		HeapNode x = q.top(); q.pop();
		int u = x.u;
		if (done[u]) continue;
		done[u] = true;
		int uu = head[u];
		while (uu)
		{
			Edge& e = edges[uu];
			if (d[e.to] > d[u] + e.dist)
			{
				d[e.to] = d[u] + e.dist;
				q.push(HeapNode(d[e.to], e.to));
			}
			uu = nextt[uu];
		}
	}
}
int main()
{
	while (scanf("%d%d", &n, &m) != EOF)
	{
		int a, b, c;
		memset(head, 0, sizeof(head));
		for (int i = 1; i <= m; i++)
		{
			scanf("%d%d%d", &a, &b, &c);
			edges[i].from = a, edges[i].to = b, edges[i].dist = c;
			nextt[i] = head[a];
			head[a] = i;
		}
		dijiktra(1);
		printf("%d\n", d[n]);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值