poj3692(二分图)

题意:幼儿园有g个女孩和b个男孩,同性之间互相认识,而且男孩和女孩之间有的也互相认识。现在要选出来最多的孩子,他们之间都互相认识。

   一道基础的二分图最大独立集问题。eg:a为男,b,c为女,a认识b,但a不认识b,所以把b除去。

 

二分图的最大独立集 = n-最小覆盖集 = n-完美匹配数。

 

   所以就转化成了二分图匹配,用匈牙利算法实现即可。

KindergartenTime Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4
AC代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#define maxn 405
using namespace std;
int n, p;
int W[maxn][maxn];
int lef[maxn];
bool T[maxn];
bool match(int i)
{
	for (int j = 1; j <= n; j++)
	{
		if (!W[i][j] && !T[j])//W[][]取反
		{
			T[j] = true;
			if (lef[j] == 0 || match(lef[j]))
			{
				lef[j] = i;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	int k;
	int cnt = 0;
	while (scanf("%d%d%d", &p, &n, &k) && p&&n&&k)
	{
		int temp, a, b;
		memset(W, 0, sizeof(W));
		memset(lef, 0, sizeof(lef));
		for (int i = 1; i <= k; i++)
		{
			scanf("%d%d", &a, &b);
			W[a][b] = 1;
		}
		int sum = 0;
		for (int i = 1; i <= p; i++)
		{
			memset(T, 0, sizeof(T));
			if (match(i))
				sum++;
		}
		printf("Case %d: %d\n", ++cnt, p + n - sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值