HDU 1394(线段树) Minimum Inversion Number

暴力也可以过,线段树最好,把每个输入的数当作线段的位置,每当输入一个数的时候 就查询 之前插入线段树中比该输入的数大的个数即可。

题目:

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 
Output
For each case, output the minimum inversion number on a single line. 
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16

AC代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#define maxn 5005
using namespace std;
int a[maxn];
struct node{
    int left;
    int right;
    int sum;
};
node tree[4*maxn];

void build(int l,int r,int no)
{
    tree[no].left=l;
    tree[no].right=r;
    tree[no].sum=0;
    if(l==r) {
        tree[no].sum=0;
        return;
    }
    int mid = (l+r)>>1;
    build(l,mid,no<<1);
    build(mid+1,r,no<<1|1);
}

int query(int l,int r,int no)
{
    if(tree[no].left==l&&tree[no].right==r) return tree[no].sum;
    int mid = (tree[no].left+tree[no].right)>>1;
    
    if(mid<l) return query(l,r,no<<1|1);
    else if(mid>=r) return query(l,r,no<<1);
    else return query(l,mid,no<<1)+query(mid+1,r,no<<1|1);
}

void update(int x,int no)
{
    int l=tree[no].left;
    int r=tree[no].right;
    if(l==r)
    {
        tree[no].sum++;
        return;
    }
    int mid=(l+r)>>1;
    if(mid>=x) update(x,no<<1);
    else update(x,no<<1|1);
    tree[no].sum=tree[no<<1].sum+tree[no<<1|1].sum;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        build(0,n-1,1);
        int sum=0;
        int ans=99999999;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            sum+=query(a[i],n-1,1);
            update(a[i],1);
        }
        if(ans>sum)
        {
            ans=sum;
        }
        for(int i=0;i<n-1;i++)
        {
            sum = sum - a[i] + n - 1 -a[i];
            if(ans>sum)
                ans=sum;
        }
        printf("%d\n",ans);
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值