hdu1394 Minimum Inversion Number (线段树)

http://acm.hdu.edu.cn/showproblem.php?pid=1394

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27295    Accepted Submission(s): 15954


 

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

 

 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

 

 

Output

For each case, output the minimum inversion number on a single line.

 

 

Sample Input

 

10 1 3 6 9 0 8 5 7 4 2

 

 

Sample Output

 

16

 

 

Author

CHEN, Gaoli

 

 

Source

ZOJ Monthly, January 2003


这个线段树里面sum存的是l 到 r之间有多少个数已经存在,类似于树状数组

#include<bits/stdc++.h>
using namespace std;

const int N = 5005;
int a[N], n;
struct node
{
	int l, r, sum;
} t[N<<2];

void build(int x, int l, int r)
{
	t[x].l = l, t[x].r = r, t[x].sum = 0;

	if(l == r) return ;

	int mid = (l + r) >> 1;
	build(x<<1, l, mid);
	build(x<<1|1, mid+1, r);
}

void update(int x, int k)//包含k的区间都要更新 
{
	t[x].sum++;

	if(t[x].l == t[x].r) return ;

	int mid = (t[x].l + t[x].r) >> 1;

	if(k <= mid) update(x<<1, k);
	if(k >  mid) update(x<<1|1, k);
}

int query(int x, int l, int r)//查询l,r之间有多少数已经存在 
{
	if(l <= t[x].l && t[x].r <= r) return t[x].sum;

	int mid = (t[x].l + t[x].r) >> 1, res=0;

	if(l <= mid) res += query(x<<1, l, r);
	if(r >  mid) res += query(x<<1|1, l, r);

	return res;
}
int main()
{
	while(cin >> n)
	{
		build(1, 1, n);

		int sum = 0, ans = 0;
		for(int i = 1; i <= n; i++)
		{
			scanf("%d", a+i);
			a[i]++;
			sum += query(1, a[i]+1, n);
			update(1, a[i]);
		}

		ans = sum;
		for(int i = 1; i < n; i++)
		{
			sum += n - a[i]  - (a[i] - 1);
			//把a[i]放后面,逆序队增加n-a[i], 减少 a[i] - 1个 
			ans = min(ans, sum);
		}

		cout << ans << endl;
	}

	return 0;
}


















 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值