poj3368 Frequent values(RMQ)

题意:找出不递减的数组a中,一段范围出现频率最大的数,解题思路,用f[n]存与a[i]之前连续的个数,当询问区间L,R时,因为f[L]可能截半,所以先找到从L起,连续相同的a[i]的个数,并且得最大位置tmp,再将个数与RMQ(tmp,R)比较,最大值就是答案。

题目:

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains nintegers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input
10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0
Sample Output
1
4
3
AC代码:

#include <stdio.h>
#include <string.h>
#include<cmath>
#include<algorithm>
#include<iostream>
#define MAX 100005
using namespace std;
int d[MAX][20];
int a[MAX];
int f[MAX];
int n, q;
void RMQ_init()
{
	for (int i = 1;i <= n;i++) d[i][0] = f[i];
	for (int j = 1;(1 << j) <= n;j++)
	for (int i = 1;i + (1 << j) - 1 <= n;i++)
	d[i][j] = max(d[i][j - 1], d[i + (1 << (j - 1))][j - 1]);
}
int RMQ(int L, int R)
{
	if (L > R)
		return 0;
	int k = 0;
	while ((1 << (k + 1)) <= R - L + 1) k++;
	return max(d[L][k], d[R - (1 << k) + 1][k]);
}
int main()
{
	while (scanf("%d", &n) &&n!=0)
	{
		scanf("%d", &q);
		a[0] = 9999999;
		for (int i = 1;i <= n;i++)
		{
			scanf("%d", &a[i]);
			if (a[i] == a[i - 1])
				f[i] = f[i - 1] + 1;
			else
				f[i] = 1;
		}
		RMQ_init();
		int L , R;
		for (int i = 0;i < q;i++)
		{
			scanf("%d %d", &L, &R);
			int tmp = L;
			int ans = 0;
			while (tmp <= R)
			{
				if (tmp == L)
				{
					ans = 1;
					tmp++;
				}
				else if (a[tmp] == a[tmp - 1])
				{
					ans++;
					tmp++;
				}
				else
				{
					break;
				}
			}
			int sum;
			if (tmp > R)
				sum = ans;
			else
				sum= max(RMQ(tmp, R), ans);
			printf("%d\n", sum);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值