POJ 3368 Frequent values(RMQ)

题目链接:http://poj.org/problem?id=3368

Frequent values
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24776 Accepted: 8632
Description

You are given a sequence of n integers a1 , a2 , … , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , … , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , … , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, …, n}) separated by spaces. You can assume that for each i ∈ {1, …, n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0
Sample Output

1
4
3
Source

Ulm Local 2007


分析:

处理的时候比较巧妙
具体看代码:

// #include <bits/stdc++.h>
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;
const int N=1e5+5;


int f[N];
int arr[N];
int dp[N][20];

void RMQ_init(int n)
{
	for(int i=1;i<=n;i++)
		dp[i][0]=f[i-1];
	for(int j=1;1<<j <=n;j++)
		for(int i=1;i+(1<<j)-1<=n;i++)
			dp[i][j]=max(dp[i][j-1],dp[i+(1<<j-1)][j-1]);
}

int query(int a,int b)
{
	if(a>b)
		return 0;
	int k=log((b-a+1)*1.0)/log(2.0);
	return max(dp[a][k],dp[b-(1<<k)+1][k]);
}

int bin(int a,int b,int tmp)//返回比tmp大的第一个位置
{
	int l=a,r=b;
	while(l<=r)
	{
		int mid=l+r>>1;
		if(arr[mid]>tmp)
		{
			if(l==r)
			{
				if(arr[r]>tmp)
					return r;
				 else 
					 r=mid;
			}
			else
				r=mid;
		}
		else
			l=mid+1;
	}
	return l;
}

int main()
{
	int n,m;
	int l , r ;
	while(scanf("%d",&n)==1&&n)
	{
		scanf("%d",&m);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&arr[i]);
			if(i==0)
			{
				f[i]=1;
			}
			else
			{
				if(arr[i]==arr[i-1])
					f[i]=f[i-1]+1;
				else
					f[i]=1;
			}
		}
		RMQ_init(n);
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&l,&r);
			int pos=bin(l-1,r-1,arr[l-1])+1;
			int ans=max(pos-l,query(pos,r));
			cout<<ans<<endl;
		}
	}
	
	
	
	return 0;
}
参考资料:
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值