HDU-Kirinriki

Kirinriki

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3009 Accepted Submission(s): 441

Problem Description

We define the distance of two strings A and B with same length n is
disA,B=∑i=0n−1|Ai−Bn−1−i|
The difference between the two characters is defined as the difference in ASCII.
You should find the maximum length of two non-overlapping substrings in given string S, and the distance between them are less then or equal to m.

Input

The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integers m : the limit distance of substring.
Then a string S follow.

Limits

T≤100
0≤m≤5000
Each character in the string is lowercase letter, 2≤|S|≤5000
∑|S|≤20000

Output

For each test case output one interge denotes the answer : the maximum length of the substring.

Sample Input

1
5
abcdefedcb

Sample Output

5

Hint

[0, 4] abcde
[5, 9] fedcb
The distance between them is abs(‘a’ - ‘b’) + abs(‘b’ - ‘c’) + abs(‘c’ - ‘d’) + abs(‘d’ - ‘e’) + abs(‘e’ - ‘f’) = 5

题目描述

给定一个整数m和一个字符串s,规定两个字符串的距离 ,在s的相同 长度子串中找出距离小于等于m的最长子串的长度

考核知识点

尺取法

常见误区

未考虑到全部区间

解题思路

我们将各个中点所在的最大区间枚举出来,求出中点,从区间的两个端点向中点缩进,并不断计算对 应的字符串距离,如果距离不满足限制条件,将两个字符串靠近区间端点的字符去掉,直到满足限制 条件再继续向中点缩进根据图可以看出有一部分中点未考虑到,所以需要将字符串倒置再计算一次,最后得出最长子串长度
这里写图片描述

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

char s[5010];
intls,m,ans;
void solve()
{
    for(int i=2; i<=ls; i++)///i用来确定区间的右边界
    {
        int o=i/2,l=0,n=0,sum=0;
        for(int j=0; j<o; j++)///从0往区间中点缩进
        {
            sum+=abs(s[j]-s[i-j-1]);///因为区间确定,左右对称的字符相应求差
            if(sum<=m)///满足限制条件,则子串长度n++
            {
                n++;
                ans = max(ans,n);
            }
            else
            {
                sum-=abs(s[l]-s[i-l-1]);///弹出靠近边界的两个
                sum-=abs(s[j]-s[i-j-1]);
                n--;
                j--;
                l++;///一直到满足条件再往里缩进
            }
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&m);
        scanf("%s",s);
        ls=strlen(s);
        ans=0;
        solve();
        reverse(s,s+ls); /// 正反各计算一遍
        solve();
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值