PAT 1041 Be Unique (20)

Being unique is so important to people on Mars that even their lotteryis designed in a unique way. The rule of winning is simple: one bets ona number chosen from [1, 10^4^]. The first one who bets on a uniquenumber wins. For example, if there are 7 people betting on 5 31 5 88 6788 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line whichbegins with a positive integer N (<=10^5^) and then followed by Nbets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is nowinner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

#include <iostream>
#include <map> 

using namespace std;
#define MAX 1<<29

int main(){
	int n;
	cin>>n;
	map<int,int> maze;
	int a;
	for(int i = 0;i < n ; i++){
		cin >> a;
		if(maze.find(a)!=maze.end()){
			maze[a] = MAX;
		}else{
			maze.insert(make_pair(a, i));
		}
	}
	int index = MAX;
	int output;
	map<int, int>::iterator it;
	for (it = maze.begin(); it != maze.end(); it++){
		if(it->second<index){
			index = it->second;
			output =  it->first ;
		}
    }
    if(index!=MAX){
    	cout << output <<endl;
	}else{
		cout << "None" <<endl;
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值