HDU5444——Elven Postman(2015年长春区域赛)

8 篇文章 0 订阅
2 篇文章 0 订阅

Elven Postman

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1699    Accepted Submission(s): 976


Problem Description
Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

 

Input
First you are given an integer  T(T10)  indicating the number of test cases.

For each test case, there is a number  n(n1000)  on a line representing the number of rooms in this tree.  n  integers representing the sequence written at the root follow, respectively  a1,...,an  where  a1,...,an{1,...,n} .

On the next line, there is a number  q  representing the number of mails to be sent. After that, there will be  q  integers  x1,...,xq  indicating the destination room number of each mail.
 

Output
For each query, output a sequence of move ( E  or  W ) the postman needs to make to deliver the mail. For that  E  means that the postman should move up the eastern branch and  W  the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
 

Sample Input
  
  
2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1
 

Sample Output
  
  
E WE EEEEE
 

Source

题意:
建立一颗二叉树,第一个输入的数字作为根节点,子节点数字大于根节点数字,则作为左孩子,否则作为右孩子。输入一个数字,在二叉树中寻找该数字。每次遍历都从根节点出发,记录寻找的路径过程,右边为东方E,左边为西方W,如果为该数字则输出空格。

解:
根据题意建立一颗二叉排序树,只是对于大小的判读进行倒置,并不会影响结果。然后进行对于树的遍历,根据题意大于给定数字的输出W反之则输出E,如果相等则输出换行。

#include<stdio.h>
#include<stdlib.h> 
#include<string.h>

typedef struct BiTNode{
    int data;                          
    struct BiTNode *lchild,*rchild;       
	}BiTNode,*BiTree;                     
int a[1005]; 

void CreatBiTree(BiTree &T,int a[],int n)
{
    BiTree p,f,s;
	   if(n<1)
	   { 
		   T=NULL;
		   return;
	   }
	   T=(BiTree)malloc(sizeof(BiTNode));
		T->data =a[0];
		T->lchild =T->rchild =NULL;
		for(int i=0;i<n;i++)
		{
			f=NULL;
			p=T;
			while(p)
			if(p->data==a[i])	break;
		else if(a[i]<p->data )
		{
			f=p;
		    p=p->lchild ;
		}
		else
		{
		        f=p;
				p=p->rchild;
}
		
		if(!p)
		{
                s=(BiTree)malloc(sizeof(BiTNode)) ;
			    s->data =a[i];
		     	s->lchild =s->rchild =NULL;
			if(s->data<f->data)
				f->lchild =s;
			  
			else 
                f->rchild=s;
		}
	}
}

void find(BiTree &T,int key)
{

	if(key==T->data)
	{
		printf("\n");
	}
	else if(key<T->data)
	{
		printf("E");
		find(T->lchild,key);
	}
	else
	{
		printf("W");
		find(T->rchild,key);
	}
}
int main()
{ 
   
   int t,n,q,x;
   while(~scanf("%d",&t))
   {
   		while(t--)
   		{
   			memset(a,0,sizeof(a));
   			BiTree T;
   			scanf("%d",&n);
   			for(int i=0;i<n;i++)
   			{
   				scanf("%d",&a[i]);
			}
   			CreatBiTree(T,a,n);
   			scanf("%d",&q);
   			for(int j=0;j<q;j++){
   				scanf("%d",&x);
   				find(T,x);
			} 
		}
   }
   return 0;
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值