HDU1200——To and Fro

10 篇文章 0 订阅
7 篇文章 0 订阅

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6441    Accepted Submission(s): 4413


Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
 

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
 

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
 

Sample Input
  
  
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0
 

Sample Output
  
  
theresnoplacelikehomeonasnowynightx thisistheeasyoneab

 题意:
根据一定规则对字符串进行加密,给定一个数字n代表了每一行所包含的字符串的数量,如此将一个字符串分成len/n行,在偶数行中是逆序排列,每一行的同一列构成一个单词,依次输出。

解:
按照题意进行模拟,首先将偶数行进行逆置,然后按照输出每一行的第一列,第二列进行输出

#include<stdio.h>
#include<string.h>

int main()
{
	int n;
	char a[210];
	char b[210];
	while(~scanf("%d",&n) && n)
	{
		getchar();
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		gets(a);
		for(int i=0;i<strlen(a);i++)
		{
			if((i/n)%2==1)
			{
				for(int j=i;j<(i+n/2);j++)
				{
					char x;
					x=a[j];
					a[j]=a[i+i+n-1-j];
					a[i+i+n-1-j]=x;
				}
				i=i+n;
			}
		}
	//	puts(a);
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<strlen(a)/n;j++)
			{
				printf("%c",a[i+j*n]);
			}
		}
		printf("\n");
	}
	return 0;
} 


   

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值