BZOJ[2763]飞行路线

2763: [JLOI2011]飞行路线
Time Limit: 10 Sec Memory Limit: 128 MB
Description
Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?
Input
数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。

第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t < n)

接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b< n,a与b不相等,0<=c<=1000)

Output

只有一行,包含一个整数,为最少花费。
Sample Input

5 6 1
0 4
0 1 5
1 2 5
2 3 5
3 4 5
2 3 3
0 2 100

Sample Output

8

飞行路线这道题不要看题目很长~其实就是一个SPFA
只需要把基础SPFA的记录结果的数组开成2维表示到第i个点用j次免费次数就OK啦!

不会SPFA的童鞋们经过这道题肯定可以明白啦!

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int x,y,c,next;
}a[2110000];int len,last[2110000];
void ins(int x,int y,int c)
{
    len++;
    a[len].x=x;a[len].y=y;a[len].c=c;
    a[len].next=last[x];last[x]=len;
}
int mymin(int x,int y)
{
    return x<y?x:y;
}
bool v[1110000][11];
int d[1110000][11];
int list[110000][11];
int head,tail;
int st,ed,n,m,K;
void SPFA()
{
    memset(v,true,sizeof(v)); v[st][0]=false;
    list[1][0]=st; list[1][1]=0;
    memset(d,63,sizeof(d));
    d[st][0]=0;
    head=1,tail=2;
    while(head!=tail)
    {
        int x=list[head][0],c=list[head][1];
        for(int k=last[x];k;k=a[k].next)
        {
            int y=a[k].y;
            if(d[x][c]+a[k].c<d[y][c])
            {
                d[y][c]=d[x][c]+a[k].c;
                if(v[y][c])
                {
                    v[y][c]=false;
                    list[tail][0]=y; list[tail][1]=c;
                    tail++;
                    if(tail==100000+1) tail=1;
                }
            }
            if(d[x][c]<d[y][c+1] && c<K)
            {
                d[y][c+1]=d[x][c];
                if(v[y][c+1])
                {
                    v[y][c+1]=false;
                    list[tail][0]=y; list[tail][1]=c+1;
                    tail++;
                    if(tail==100000+1) tail=1;
                }
            }
        }
        v[x][c]=true;
        head++;
        if(head==100000+1) head=1;
    }
}
int main()
{
    scanf("%d%d%d",&n,&m,&K);
    scanf("%d%d",&st,&ed);
    for(int i=1;i<=m;i++)
    {
        int x,y,c;
        scanf("%d%d%d",&x,&y,&c);
        ins(x,y,c);
        ins(y,x,c);
    }
    SPFA();
    int ans=99999999;
    for(int i=0;i<=K;i++) ans=mymin(ans,d[ed][i]);
    printf("%d\n",ans);
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值