SWUST OJ 56 Hamming Distance

swust oj 56

题目描述

Have you ever heard of the Hamming distance? It is the number of positions for which the corresponding digits differ. Your task is to write a program that computes this distance for two binary strings.

输入

The input contains several test cases. Each test case consists of two lines. Each line contains one binary number. Any two numbers given in one test case have the same length, which is at most 100 binary digits. The last test case is followed by a line containing the uppercase letter “X”.

输出

Your program must output a single line for each test case. The line should contain the statement “Hamming distance is X.”, where X is the number of positions where the two numbers have different digits.

样例输入

在这里插入图片描述

样例输出在这里插入图片描述

源代码

#include<stdio.h> 
#include<string.h>
int main()
{
	char s[100],a[100];
	int n;
	while(scanf("%s",&s)!=EOF)
	{
	     getchar();
	     if(s[0]=='X')
	     break;
		 scanf("%s",&a);
	     n=strlen(s);
      int m=0;
    for(int i=0;i<n;i++)
	{
		if(s[i]!=a[i])
		 m++;
	}
   printf("Hamming distance is %d.\n",m);
	}
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

大林不要掉头发

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值