56: Hamming Distance
题目描述
Have you ever heard of the Hamming distance? It is the number of positions for which the corresponding digits differ. Your task is to write a program that computes this distance for two binary strings.
输入
The input contains several test cases. Each test case consists of twolines. Each line contains one binary number. Any two numbers given inone test case have the same length, which is at most 100 binarydigits. The last test case is followed by a line containing the uppercase letter “X”.
输出
Your program must output a single line for each test case. The line should contain the statement “Hamming distance is X.”, where X is the number of positions where the two numbers have different digits.
样例输入
0
1
000
000
1111111100000000
0000000011111111
101
000
X
样例输出
Hamming distance is 1.
Hamming distance is 0.
Hamming distance is 16.
Hamming distance is 2.
#include<bits/stdc++.h>
using namespace std;
int main()
{
char a[100],b[100];
int i, len, n;
while(scanf("%s", a)!=EOF) //多组输入字符串a
{
n = 0;
if(a[0]=='X') break; //若为X则跳出循环
len = strlen(a);
scanf("%s", b); //输入字符串b
for(i = 0; i < len; i++)
{
if(a[i]!=b[i]) n++; //逐个字符比较,若字符不同则距离加一
}
printf("Hamming distance is %d.\n", n);
}
return 0;
}
以上方法仅供参考,欢迎互联网的广大朋友们提出指正。