SWUST OJ 56: Hamming Distance

56: Hamming Distance
题目描述
Have you ever heard of the Hamming distance? It is the number of positions for which the corresponding digits differ. Your task is to write a program that computes this distance for two binary strings.

输入

The input contains several test cases. Each test case consists of twolines. Each line contains one binary number. Any two numbers given inone test case have the same length, which is at most 100 binarydigits. The last test case is followed by a line containing the uppercase letter “X”.

输出

Your program must output a single line for each test case. The line should contain the statement “Hamming distance is X.”, where X is the number of positions where the two numbers have different digits.

样例输入

0
1
000
000
1111111100000000
0000000011111111
101
000
X

样例输出

Hamming distance is 1.
Hamming distance is 0.
Hamming distance is 16.
Hamming distance is 2.

#include<bits/stdc++.h>
using namespace std;
int main()
{
    char a[100],b[100];
    int i, len, n;
    while(scanf("%s", a)!=EOF)     //多组输入字符串a
    {
        n = 0;
        if(a[0]=='X') break;        //若为X则跳出循环
        len = strlen(a);
        scanf("%s", b);             //输入字符串b
        for(i = 0; i < len; i++)    
        {
            if(a[i]!=b[i]) n++;     //逐个字符比较,若字符不同则距离加一
        }
        printf("Hamming distance is %d.\n", n);
    }
    return 0;
}

以上方法仅供参考,欢迎互联网的广大朋友们提出指正。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值