Time Limit: 1000MS Memory limit: 65536K
题目描述
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
输入
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
输出
输出合并后的单链表所包含的M+N个有序的整数。
示例输入
6 5
1 23 26 45 66 99
14 21 28 50 100
示例输出
1 14 21 23 26 28 45 50 66 99 100
提示
不得使用数组!
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node{
int data;
struct node *next;
};
struct node *creat(int n)
{
int i;
struct node *head,*p,*tail;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++){
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=tail->next;
}
return head;
}
struct node *merge(struct node *a,struct node *b)
{
struct node *head,*tail;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
while(a&&b){
if(a->data<b->data){
tail->next=a;
tail=tail->next;
a=a->next;
}
else{
tail->next=b;
tail=tail->next;
b=b->next;
}
}
if(a) tail->next=a;
else tail->next=b;
return head;
}
int main()
{
int n,m;
struct node *p,*q,*head;
scanf("%d%d",&m,&n);
p=creat(m);
q=creat(n);
p=p->next;
q=q->next;
head=merge(p,q);
head=head->next;
while(head->next!=NULL){
printf("%d ",head->data);
head=head->next;
}
printf("%d\n",head->data);
return 0;
}