Time Limit: 1000MS Memory limit: 4096K
题目描述
输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。
输入
第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。
输出
第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。
示例输入
10
56 25 12 33 66 54 7 12 33 12
12
示例输出
10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int n;
struct node{
int data;
struct node *next;
};
struct node *creat(int n)
{
int i;
struct node *head,*tail,*p;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++){
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=tail->next;
}
return head;
}
struct node *delet(struct node *head,int m)
{
struct node *tail,*p;
tail=head;
while(tail->next!=NULL){
p=tail->next;
if(p->data==m){
tail->next=p->next;
free(p);
n--;
}
else tail=tail->next;
}
return head;
}
int main()
{
int m;
struct node *head,*p;
scanf("%d",&n);
head=creat(n);
scanf("%d",&m);
p=head->next;
printf("%d\n",n);
while(p->next!=NULL){
printf("%d ",p->data);
p=p->next;
}
printf("%d\n",p->data);
head=delet(head,m);
p=head->next;
printf("%d\n",n);
while(p->next!=NULL){
printf("%d ",p->data);
p=p->next;
}
printf("%d\n",p->data);
return 0;
}