7-6 树的遍历(知后续和中序 建树层次遍历输出

7-6 树的遍历(25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

 
   

4 1 6 3 5 7 2

/*
7-6 树的遍历
*/
#include<stdio.h>
#include<stdlib.h>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
int hou[1000],zhong[1000];
struct node{
	int data;
	struct node *left,*right;
}T;
struct node *creat(int hou[],int zhong[],int n){
	int i,k,root;
	if(n==0)
	 return NULL;
	struct node *T;
	T=(struct node *)malloc(sizeof(struct node));
	root=hou[n-1];
	T->data=root;
	for(i=0;i<n;i++){
		if(zhong[i]==root){
			k=i;
			break;
		}
	}
	T->left=creat(hou,zhong,k);
	T->right=creat(hou+k,zhong+k+1,n-k-1);
	return T;
}
void cengci(struct node *T,int n){
   struct node* p[1000],*q;
   int f=0,r=0;
   int num=0;
   if(T){
   	 p[r++]=T;
   	 while(f!=r){
   	 	q=p[f++];
   	 	printf("%d",q->data);
   	 	num++;
   	 	if(num<n)
   	 	 cout<<" ";
   	 	if(q->left){
   	 		p[r++]=q->left;
			}
		if(q->right){
			p[r++]=q->right;
		}
		}
   }	
}
int main(){
	int n,i;
	struct node *T;
    cin>>n;
    for(i=0;i<n;i++)
     cin>>hou[i];
    for(i=0;i<n;i++)
     cin>>zhong[i];
    T=creat(hou,zhong,n);
    cengci(T,n);
    return 0;
} 


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值