D - Ignatius and the Princess IV

D - Ignatius and the Princess IV


"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

Input The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
Output For each test case, you have to output only one line which contains the special number you have found.
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
Sample Output
3
5
1

方法一:来一个数字,我就记录这个数字输入的次数,输入次数最多的,肯定是最后要输出的,因为题目保证了答案的唯一性

注:之前提交的时候,n,i,j 都定义成了int,结果没有过,定义成longlong就过了 ,不太建议用排序,容易超时,

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int a[1000005];
int cnt[1000005];
int main(){
long long int n,i,j; 
while(scanf("%lld",&n)!=EOF){
    for(i=0;i<n;i++){
    scanf("%d",&a[i]);
     cnt[a[i]]++;
     if(cnt[a[i]]>=(n+1)/2){
        j=a[i];
      //  break;
     }
    }
 printf("%lld\n",j);

}
return 0;
}

方法二:题目中让我们找的是数字个数比其他的都多的,我用cnt来记录输入的数字的个数,当输入一个数字之后,我就用result来记录这个数字,然后cnt就标记为1,当再次输入数字的时候,就让又输入的数字与上一个数字(result)作比较,如果相等的话cnt继续做加1操作(相当于累加),如果不一样的话,cnt就做减一操作(相当于两个数字抵消)。


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main(){
  long long int cnt=0;
  long long int n,i,t,result;
while(scanf("%lld",&n)!=EOF){
        cnt=0;//细节问题,每一次重新输入后,cnt都要置0;
 for(i=0;i<n;i++){
    scanf("%lld",&t);
    if(cnt==0){
        result=t;
        cnt=1;
    }else{
     if(result == t)
        cnt++;
      else
        cnt--;
    }
  }
  printf("%lld\n",result);
      }
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值