博弈——Play a game

New Year is Coming! 
ailyanlu is very happy today! and he is playing a chessboard game with 8600. 
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can't make a move will lose the game. If both play perfectly, who will win the game?
Input
The input is a sequence of positive integers each in a separate line. 
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.
Output
Output the winner ("8600" or "ailyanlu") for each input line except the last zero. 
No other characters should be inserted in the output.
Sample Input
2
0
Sample Output
8600

题意:ailyanlu和8600玩游戏,有一个边长为n的正方形棋盘,棋子最开始在棋盘的某一个角落,玩家轮流移动这颗棋子,每回合可以移动到这颗棋子的前后左右且之前没移动到的格子,如果某个玩家不能移动棋子,则为输。8600先移动,输出赢家。

思路:

8600的最小必败态是n=1,n=1又可以转移到n=2,同样n=2可以转移到n=3,这样推下去,就是n是奇数是ailyanlu赢,否则8600赢。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
    int n;
    while(~scanf("%d", &n)&&n)
    {
        if(n&1)
            printf("ailyanlu\n");
        else
            printf("8600\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值