Play a game(博弈)(巴什博弈)

Problem Description 
New Year is Coming! 
ailyanlu is very happy today! and he is playing a chessboard game with 8600. 
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game. If both play perfectly, who will win the game?

Input 
The input is a sequence of positive integers each in a separate line. 
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output 
Output the winner (“8600” or “ailyanlu”) for each input line except the last zero. 
No other characters should be inserted in the output.

Sample Input 

0

Sample Output 
8600

题意:有一个n*n的表格,现在将一块石头放在某个位置,然后每个人来移动,每次只能移动一格,最后一个谁移动那么就谁赢。ailyanlu先移动,8600后手。

 

题目很简单,但是可以理解一下巴什博弈。(如果有n个物品,每次走m个,先走完胜,那么n%(m+1)==0时操作为必胜状态)。那么这里就是走完n*n-1个格子,每次走一步(应该可以验证如果一方愿意,可以遍历所有的格子,虽然我并不会证明 o.o),那么n为n*n-1,m为1,如果(n*n-1)%(1+1)==0则后手必胜。

 

简化一下,n*n-1简化为n*n(结果相反),再简化为n

 

#include <bits\stdc++.h>
using namespace std;



int main()
{
    int a;
    while(scanf("%d",&a),a)
    {
        if(a&1) printf("ailyanlu\n");
        else printf("8600\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值