动态规划——巴比伦塔

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story: The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi , yi , zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked. Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values xi , yi and zi . Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format ‘Case case: maximum height = height’

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:

给n种立方体,每种无限个,要求将这些立方体堆叠起来,求堆叠的最大高度,堆叠规则是在下面的立方体的长和宽必须严格大于在上面的。

输入以0结束


思路:

将立方体的三种放法都保存下来,之后可以直接暴力dp求解。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <stack>
#define INF 0x3f3f3f3f
#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
const int maxn=35;
struct node
{
    int a, b, c;
}t[maxn*3];
int dp[maxn*3];
int n;
int solve(int x)
{
    if(dp[x]!=-1)
        return dp[x];
    dp[x]=t[x].c;
    for(int i=1; i<=n; i++)
        if((t[x].a>t[i].a&&t[x].b>t[i].b)||(t[x].a>t[i].b&&t[x].b>t[i].a))
            dp[x]=max(dp[x], solve(i)+t[x].c);
    return dp[x];
}
int main()
{
    int cas=0;
    while(~scanf("%d", &n)&&n)
    {
        n*=3;
        memset(dp, -1, sizeof(dp));
        for(int i=1; i<=n;)
        {
            int x, y, z;
            scanf("%d%d%d", &x, &y, &z);
            t[i].a=x; t[i].b=y; t[i].c=z; i++;
            t[i].a=y; t[i].b=z; t[i].c=x; i++;
            t[i].a=z; t[i].b=x; t[i].c=y; i++;
        }
        int ans=0;
        for(int i=1; i<=n; i++)
            ans=max(ans, solve(i));
        printf("Case %d: maximum height = %d\n", ++cas, ans);
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值