UVA-315 Network(割点)

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting
several places numbered by integers from 1 to N. No two places have the same number. The lines
are bidirectional and always connect together two places and in each place the lines end in a telephone
exchange. There is one telephone exchange in each place. From each place it is possible to reach
through lines every other place, however it need not be a direct connection, it can go through several
exchanges. From time to time the power supply fails at a place and then the exchange does not operate.
The officials from TLC realized that in such a case it can happen that besides the fact that the place
with the failure is unreachable, this can also cause that some other places cannot connect to each other.
In such a case we will say the place (where the failure occured) is critical. Now the officials are trying
to write a program for finding the number of all such critical places. Help them.
Input
The input file consists of several blocks of lines. Each block describes one network. In the first line
of each block there is the number of places N < 100. Each of the next at most N lines contains the
number of a place followed by the numbers of some places to which there is a direct line from this place.
These at most N lines completely describe the network, i.e., each direct connection of two places in
the network is contained at least in one row. All numbers in one line are separated by one space. Each
block ends with a line containing just ‘0’. The last block has only one line with N = 0.
Output
The output contains for each block except the last in the input file one line containing the number of
critical places.
Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output
1
2

题意: 一个无相图,他们之间可以相互到达,若删除某个点,他们就不能相互到达,求这样的点的个数。
**思路:**求割点数目,模板

#include<bits/stdc++.h>
using namespace std;
const int MAXN = 1e5+10;
struct EDGE
{
    int v,next;
}e[MAXN];
int n,m;
int cnt;
int head[MAXN],dfn[MAXN],low[MAXN],tot;
int father[MAXN];
bool is_cut[MAXN];

void init()
{
    for(int i=0;i<=n;i++){
        dfn[i] = low[i] = head[i] = -1;
        father[i] = 0;
        is_cut[i] = false;
    }
    tot = cnt = 0;
}

void Tarjan(int x,int pre)
{

    father[x] = pre;
    dfn[x] = low[x] = ++tot;

    for(int j = head[x];~j;j = e[j].next){
        int v = e[j].v;
        if(dfn[v] == -1){
            Tarjan(v,x);
            low[x] = min(low[x],low[v]);
        }
        else if(pre != v)   //假如k是i的父亲,那么这条边就是无向边的重边,那么就一定不是桥
        {
            low[x] = min(low[x],dfn[v]);//可能dfn[k]!=low[k],所以不能用low[k]代替dfn[k],否者会翻过头
        }
    }
}

void addedge(int u,int v)
{
    e[cnt].v = v;
    e[cnt].next = head[u];
    head[u] = cnt++;
}

int main()
{
    int u,v;
    while (~scanf("%d", &n), n)
    {
        init();

        while (scanf("%d", &u), u)
        {
            while (getchar() != '\n')
            {
                scanf("%d", &v);
                addedge (u, v);
                addedge (v, u);
            }
        }

        Tarjan(1,0);
        int root = 0;
        for(int i=2;i<=n;i++){
            int temp = father[i];
            if(temp==1) root++;
            else{
                if(low[i] >= dfn[temp])//割点条件
                    is_cut[temp] = true;
            }
        }
        if(root>1)  is_cut[1]=true;
        int sum=0;
        for(int i=1;i<=n;i++)
            if(is_cut[i])   sum++;
        printf("%d\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值