HDU-4738 Caocao's Bridges(边强连通分量)

题目链接
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn’t give up. Caocao’s army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao’s army could easily attack Zhou Yu’s troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao’s army could be deployed very conveniently among those islands. Zhou Yu couldn’t stand with that, so he wanted to destroy some Caocao’s bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn’t be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn’t succeed any way, print -1 instead.
Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0
Sample Output
-1
4

题意: 有n个岛屿,他们之间有m条桥梁链接,现在需要炸毁一条桥梁,使得岛屿断开连接。每条桥上都有士兵把守,派去轰炸桥梁的士兵人数不得少于把手人数,问至少需要多少名士兵?

思路: 边的强连通分量水题,分下面几种情况。
如果是森林,则不需要派遣士兵。
如果没有桥,则必定失败。
如果桥上没有士兵把守,则最少需要一人。
否在,输出所有桥中人数最少的数量。

#include<bits/stdc++.h>
using namespace std;
const int MAXN = 1100;
const int MAXM = 1e6+10;
struct Edge
{
    int v,w,next;
}e[MAXM<<1];
int head[MAXN],cnt;
int low[MAXN],dfn[MAXN],tot;
int n,m,mi;

void init()
{
    for(int i=0;i<=n;i++){
        head[i] = -1;
        low[i] = dfn[i] = 0;
    }
    cnt = tot = 0;
    mi = (1<<30);
}

void addedge(int u,int v,int w)
{
    e[cnt].v = v;
    e[cnt].w = w;
    e[cnt].next = head[u];
    head[u] = cnt++;

    e[cnt].v = u;
    e[cnt].w = w;
    e[cnt].next = head[v];
    head[v] = cnt++;
}

void Tarjan(int u,int father)
{
    dfn[u] = low[u] = ++tot;
    int flag = 0;
    for(int i=head[u];~i;i=e[i].next){
        int v = e[i].v;
        if(v == father && !flag){ flag = 1;continue; }
        if(!dfn[v]){
            Tarjan(v,u);
            low[u] = min(low[u],low[v]);
            if(low[v] > dfn[u]) mi = min(mi,e[i].w);
        }
        else
            low[u] = min(low[u],dfn[v]);
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m),n+m){
        init();
        while(m--){
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            addedge(x,y,w);
        }
        int sum = 0;
        for(int i=1;i<=n;i++){
            if(!dfn[i]) sum++,
                Tarjan(i,0);
        }
        if(sum >= 2)    cout<<0<<endl;
        else if(mi == (1<<30))   cout<<-1<<endl;
        else if(mi == 0)    cout<<1<<endl;
        else cout<<mi<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值