POJ 2926 Requirements (多维曼哈顿最远距离)

Requirements

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4491 Accepted: 1570

Description

An undergraduate student, realizing that he needs to do research to improve his chances of being accepted to graduate school, decided that it is now time to do some independent research. Of course, he has decided to do research in the most important domain: the requirements he must fulfill to graduate from his undergraduate university. First, he discovered (to his surprise) that he has to fulfill 5 distinct requirements: the general institute requirement, the writing requirement, the science requirement, the foreign-language requirement, and the field-of-specialization requirement. Formally, a requirement is a fixed number of classes that he has to take during his undergraduate years. Thus, for example, the foreign language requirement specifies that the student has to take 4 classes to fulfill this requirement: French I, French II, French III, and French IV. Having analyzed the immense multitude of the classes that need to be taken to fulfill the different requirements, our student became a little depressed about his undergraduate university: there are so many classes to take…

Dejected, the student began studying the requirements of other universities that he might have chosen after high school. He found that, in fact, other universities had exactly the same 5 requirements as his own university. The only difference was that different universities had different number of classes to be satisfied in each of the five requirement.

Still, it appeared that universities have pretty similar requirements (all of them require a lot of classes), so he hypothesized that no two universities are very dissimilar in their requirements. He defined the dissimilarity of two universities X and Y as |x1 − y1| + |x2 − y2| + |x3 − y3| + |x4 − y4| + |x5 − y5|, where an xi (yi) is the number of classes in the requirement i of university X (Y) multiplied by an appropriate factor that measures hardness of the corresponding requirement at the corresponding university.

Input

The first line of the input file contains an integer N (1 ≤ N ≤ 100 000), the number of considered universities. The following N lines each describe the requirements of a university. A university X is described by the five non-negative real numbers xxxxx5.

Output

On a single line, print the dissimilarity value of the two most dissimilar universities. Your answer should be rounded to exactly two decimal places.

Sample Input

3
2 5 6 2 1.5
1.2 3 2 5 4
7 5 3 2 5

Sample Output

12.80

Source

MIT Programming Contest 2005

题意:给你n(n<=1e5)个5维点的坐标,让你求曼哈顿距离最远的两个点的距离。

思路:算是个结论吧,首先,暴力枚举肯定超时。

于是我们先考虑二维空间上两个坐标之间的曼哈顿距离(x1, y1) 和 (x2, y2),|x1-x2| +|y1-y2|去掉绝对值符号后共有下列四种情况:

(x1-x2) + (y1-y2)

(x1-x2) + (y2-y1)

(x2-x1) + (y1-y2)

(x2-x1) + (y2-y1)

显然,任意给两个点,我们分别计算上述四种情况,那么最大值就是曼哈顿距离。

转化一下:

(x1+y1) - (x2+y2)

(x1-y1) - (x2-y2)

(-x1+y1) - (-x2+y2)

(-x1-y1) - (-x2-y2)

你发现了什么!

转化后,“-”号两侧的坐标形式是一样的。维数为5,因此我们可以用二进制枚举。

最大曼哈顿距离 = max {每种情况下的最大值-最小值}

这个小技巧可以结合许多知识点运用。

代码:

//#include <bits/stdc++.h>   //poj不支持万能头文件!!!
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<iostream>
#include<iomanip>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=5e5+10;
double a[maxn][6];
double ans,tmp,cnt;
double mi,ma;
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<5;j++)
        scanf("%lf",&a[i][j]);
    }
    ans=-inf;
    for(int k=0;k<(1<<5);k++)
    {
        mi=inf;ma=-inf;
        for(int i=0;i<n;i++)
        {
            double tmp=0;
            for(int j=0;j<5;j++)
            if(k&(1<<j))tmp+=a[i][j];
            else tmp-=a[i][j];
            ma=max(ma,tmp);
            mi=min(mi,tmp);
        }
        ans=max(ans,ma-mi);
    }
    cout<<fixed<<setprecision(2)<<ans<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值