HDU 3374 String Problem (字符串最小表示法+KMP)

String Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4951    Accepted Submission(s): 2014


 

Problem Description

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank 
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

 

 

Input

  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

 

 

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

 

 

Sample Input

 

abcder aaaaaa ababab

 

 

Sample Output

 

1 1 6 1 1 6 1 6 1 3 2 3

题意:

给你一个字符串(长度不超过1e6),字符串是一个环,让你求其中字典序最小和最大的,并求其出现的次数(在整个环中)。

思路:

字符串的最小表示法求出最小、最大字典序的串,然后kmp跑就行了。

代码:

#include<iostream>
#include<iomanip>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=2000010;
char str[maxn];
char s[maxn],p[maxn];
int len;
int n,m,nxt[maxn];
int cnt,as[maxn],ans;
void getfail()
{
    int i=0,j=-1;
    nxt[0]=-1;
    while(i<len)
    {
        if(j==-1||p[i]==p[j])
        {
            i++;j++;
            nxt[i]=j;
        }
        else j=nxt[j];
    }
}
void kmp(int &ans)
{
    int k,i,j;
    getfail();
    i=0;j=0;
    while(i<m)
    {
        if(j==-1||s[i]==p[j])
        {
            i++;j++;
        }
        else j=nxt[j];
        if(j==len) ans++;
    }
}
int find_pos()
{
    int p1=0,p2=1,k=0;
    while(p1<len&&p2<len&&k<len)
    {
        int tmp=str[(p1+k)%len]-str[(p2+k)%len];
        if(!tmp) k++;
        else
        {
            tmp>0?p1+=k+1:p2+=k+1;
            if(p1==p2) p2++;
            k=0;
        }
    }
    return min(p1,p2);
}
int find_pos2()
{
    int p1=0,p2=1,k=0;
    while(p1<len&&p2<len&&k<len)
    {
        int tmp=str[(p1+k)%len]-str[(p2+k)%len];
        if(!tmp) k++;
        else
        {
            tmp<0?p1+=k+1:p2+=k+1;
            if(p1==p2) p2++;
            k=0;
        }
    }
    return min(p1,p2);
}
void go()
{
    int id1,ans1=0,id2,ans2=0;
    int pos=find_pos();
    id1=pos+1;
    int l=0;
    for(int i=pos;i<len+pos;i++)
    {
        p[l++]=str[i%len];
    }
    p[len]='\0';
    kmp(ans1);
    pos=find_pos2();
    id2=pos+1;
    l=0;
    for(int i=pos;i<len+pos;i++)
    {
        p[l++]=str[i%len];
    }
    p[len]='\0';
    kmp(ans2);
    printf("%d %d %d %d\n",id1,ans1,id2,ans2);
}

int main()
{
    int t,i,cas=1;
    while(scanf("%s",s)!=EOF)
    {
        len=strlen(s);
        for(int i=0;i<len;i++)
        {
            str[i]=s[i];
            s[i+len]=s[i];
        }
        str[len]='\0';
        s[2*len-1]='\0';
        m=2*len-1;
        go();
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值